ATLauncher Forums

Full Version: (FAQ) Common Questions, Problems and Fixes
You're currently viewing a stripped down version of our content. View the full version with proper formatting.

(FAQ) Common Questions, Problems and Fixes - dgelessus

This thread lists a number of common issues and problems that you might have with the launcher or the modpacks. Before making a post and asking others for help, please look through this list and see if your issue is listed here. This can get your problem fixed much more quickly than by making a support thread.

Contents
  1. General Problems
    1. I have a problem/My game is crashing/I encountered a bug!
    2. Which version of Java should I be using?
    3. But I thought Java 8 was bad for Minecraft and that I should use Java 7!
    4. I downloaded the launcher, where can I find it?
  2. Launcher Problems
    1. When I try to start the launcher, it can't find a Java Runtime Environment/it asks me what program to open jar files with!
    2. When I try to start the exe version of the launcher, nothing happens!
    3. My antivirus program says the launcher is a virus!
    4. I'm on a Mac and it says the app is damaged!
    5. I can't log in with my Minecraft account!
    6. The launcher can't download a file/pack!
    7. I'm on Windows and the launcher window is really small on my high DPI display!
    8. I'm on Windows, and the main launcher window never shows, and this error appears multiple times in the console: [...]
    9. I'm on a Mac, and when I download one of the mods through my browser, it becomes a folder instead of a zip file!
    10. I'm on Linux and the launcher window is completely blank!
  3. Modpack Problems
    1. The game crashes because it runs out of memory, what are good RAM settings that I can use?
    2. How do I update my drivers so they work with Minecraft?
    3. I updated my instance and it crashes before I get to the main menu!
    4. I'm on Windows 10, and the game hangs/crashes while loading!
    5. The game crashes after step 7/7 on the loading bar, with this exception: [...]
    6. The game randomly crashes with one of these exceptions: [...]
    7. I'm trying to play an old 1.6 modpack, and the game crashes with this exception: [...]
  4. Server Problems
    1. I'm on Windows and get this error: [...]
    2. I'm on a Mac and have problems running a server!
    3. The server crashes before starting up and shows no clear error message or traceback!
    4. I can start and join my server, but I can't find any mod resources and I can't craft any modded items!
    5. I have a server on an old modpack version, how do I update it to the current version?



General Problems

I have a problem/My game is crashing/I encountered a bug!
First of all, follow these simple steps. This will only take you a few minutes, and can fix some issues very quickly. After every step, try again and see if your problem still exists.
  1. Restart the game/launcher/computer.
  2. Make sure that you're running the latest version of the launcher. Go to the ATLauncher Downloads page and check that your launcher version is the same as (or newer than) the latest version in the Changelog section. If not, you need to manually redownload the launcher exe (Windows) or jar (other systems) and place it in your launcher folder (click Open Folder in the main launcher window). The launcher must not run when you do this!
  3. Make sure that you have the recommended version of Java installed. Near the top of the launcher log you can see your current Java version - make sure that the one listed next to "Minecraft" is the one recommended in the next question.
  4. If your game is crashing or you have graphics-related issues, update your graphics drivers to the latest version. See this FAQ entry for details.


Which version of Java should I be using?
The answer is simple - the latest version of Java 8 that you can get from the Java Downloads page. If you're on Windows or Linux and your operating system is a 64-bit (x64) version, it is important that you install the 64-bit version, not the 32-bit one. On Windows you should also uninstall all old Java versions before installing the latest version, otherwise an old version might remain the default.

If you update to the next major Java release (Java 9) when it comes out, you may encounter problems. Major Java updates include changes that can (and often will) break old code, which means that Minecraft, Forge and the mods may need to be updated to work properly. If you don't mind crashes or losing your progress, then please do install the new Java version and report any problems to the modpack authors or mod developers! However if you're running a server you should stay on the previous Java release until your pack is known to work on the new version.

But I thought Java 8 was bad for Minecraft and that I should use Java 7!
Yes, that was the case a while ago when Java 8 was relatively new. One of the early Java 8 updates uncovered a bug in Forge that would crash the game on launch, and the only way to avoid the crash was to use Java 7. This bug has been fixed in later versions of Forge, and old modpacks with old Forge versions can be patched by installing the Legacy Java Fixer, meaning that modded Minecraft is now fully compatible with Java 8. Java 7 is no longer being updated, which means that it is likely to cause compatibility problems and security issues in the future, so it is recommended to update to Java 8.

I downloaded the launcher, where can I find it?
Almost all operating systems have a Downloads folder for every user. If your browser didn't ask you where you want to save the launcher, that's where it was most likely downloaded to. Do not run the launcher in the Downloads folder! Instead, make a new folder on your desktop or in your user or documents folder, and put the launcher exe/jar there. If you've downloaded the Mac app, you don't need to make a new folder, just put the launcher app in your user/desktop/documents folder.
If you told your browser to "open" the launcher, instead of "save", it was probably downloaded to a temporary folder. Depending on what browser you use it may have been deleted when you closed the launcher or the browser. Download it again and save it normally.


Launcher Problems

When I try to start the launcher, it can't find a Java Runtime Environment/it asks me what program to open jar files with!
Either you don't have Java installed at all, or your Java installation is broken. See step 3 of the first issue on how to install the right Java version for your system.

When I try to start the exe version of the launcher, nothing happens!
Check your task bar and see if the launcher window opened in the background. If no window appeared, download the jar version of the launcher and try running it instead.

My antivirus program says the launcher is a virus!
The official download site is at https://atlauncher.com/downloads/, and that is the only place where you should download the launcher. You should never download the launcher from anywhere else - if you're lucky you just get an outdated version, but it is possible that other websites provide versions of the launcher that contain malware or viruses. (The ATLauncher development build server is of course safe as well, but you shouldn't get a development version of the launcher unless you know what you're doing.) If you got the launcher from the official download site and it is still recognized as a virus, then your antivirus program is probably overreacting. If the number of players, modpacks and active users on the forums doesn't convince you that the launcher is not just a virus, you can look through the source code and see for yourself.

I'm on a Mac and it says the app is damaged!
Newer versions of OS X distrust apps that are not verified by Apple and will report them as "damaged". First of all, read the above problem and make sure that you got the launcher from the real download site. If you're sure that you've downloaded a safe version of the launcher, follow these steps:
Open your System Preferences, go to Security, select the first tab. Click the lock and enter your admin account data. (This is necessary to change some of the settings. Your username and password are only used by OS X to check that you have admin rights on your computer - they will not be sent anywhere.) Then set Allow applications downloaded from to Everywhere. Start the launcher, then change the setting back to what it was on before.
Should this fix not work, download the Linux/jar version of the launcher, place it in a new empty folder, and run the ATLauncher.jar instead.

I can't log in with my Minecraft account!
Check if you can log in on https://minecraft.net/ and with the regular Minecraft launcher.
  • If you can't log in there either, check https://help.mojang.com/, the servers may be down. If the servers are up and you still can't log in, you need to contact Mojang support.
  • If you can log in on the website, but not in the ATLauncher, make sure you're using exactly the same username/email and password. Also read the next issue.

The launcher can't download a file/pack!
Something is probably blocking your download, such as your antivirus program or firewall, a child safety program, or the internet filter of your router or school/uni/workplace internet proxy.
Make sure that Java is allowed to access the internet, and if possible add all servers on https://atlauncher.com/help/whitelist/ to your firewall or internet filter whitelist. It may also be necessary to exclude the ATLauncher exe/app/jar from virus scans.
If your antivirus program includes an ad blocker, you may need to disable that - some files on the Minecraft download servers are incorrectly recognized as ads, because they have the word "ad" in the path.
If this does not solve your issue, please make a ZIP file of the FailedDownloads folder in the launcher folder. (On Windows, right-click on the FailedDownloads folder, and in the Send to menu click on Compressed (zippped) folder. On Mac, hold the ctrl key and click on the FailedDownloads folder, then click on Compress “FailedDownloads”.) Then make a post in the Cannot Download Packs thread, and include the ZIP file of the FailedDownloads folder, and a link to your uploaded console log.

I'm on Windows and the launcher window is really small on my high DPI display!
This is an issue with Java not properly telling Windows that it does not support high DPI displays. To fix this, right-click on the launcher exe, go to Properties, go to the Compatibility tab and enable the checkbox "Disable display scaling on high DPI settings".

I'm on Windows, and the main launcher window never shows, and this error appears multiple times in the console:
Code:
Unrecognized Windows Sockets error: 10106: create
Open the Command Prompt with admin rights. Find it under Start > All Programs > Accessories > Command Prompt, right-click it, and select Run as Administrator. If your current user account does not have admin rights, you'll need to enter the data for an admin account on your computer. In the command prompt, type the following command, then press Enter:
Code:
netsh winsock reset catalog
Close the command prompt window and restart your computer.

I'm on a Mac, and when I download one of the mods through my browser, it becomes a folder instead of a zip file!
Safari has an option to automatically open "safe" files after download, which is enabled by default. This includes archives like zip files. Go into Safari's preferences and disable that option.

I'm on Linux and the launcher window is completely blank!
This is an issue with Java's GUI framework (AWT) and certain window managers. It may help if you run the launcher using the following command:
Code:
_JAVA_AWT_WM_NONREPARENTING=1 java -jar ATLauncher.jar
You need to run this command in the launcher folder or replace ATLauncher.jar with the absolute path to the launcher. If that solves the issue, you might want to put this line in a shell script so you can run it easily.


Modpack Problems

The game crashes because it runs out of memory, what are good RAM settings that I can use?
This depends on what system you're using and how much RAM your computer has, and there are no "perfect" RAM settings. But no matter what your system is, you should use Java 8 instead of an older version. Java 8 removes what was previously called "PermGen space" and replaces it with "Metaspace". The difference is that Metaspace changes size automatically, which means one less RAM setting to worry about.

If your operating system is a 32-bit version, you are limited in how much RAM a single program, such as Minecraft, can use to about 1 GB. This is not enough for most new and large modpacks, most likely you'll only be able to play modpacks with a small amount of mods. Set the initial RAM to 256 MB and the maximum to 1024 MB, this will make the best use of the available RAM.

If your operating system is a 64-bit version, make sure that you are using a 64-bit version of Java, otherwise you will suffer the same limitations as on a 32-bit system! The initial RAM should be somewhere between 256 and 1024 MB, anything higher will likely make Java use more memory than it really needs. The maximum value depends on how much RAM your computer has. In general you should always leave at least 1 GB free for your OS and other programs to use, and never set the maximum higher than 4 GB (or 6 GB if you're using a HD resource pack like Faithful or Sphax). For example, if your computer has 4 GB of RAM, you can set the maximum to 3 GB, meaning that there is always at least 1 GB free. If you have 8 GB or more, then 4 GB is a safe maximum.

How do I update my drivers so they work with Minecraft?
  • First of all, see Mojang's support page and follow the instructions there to update your drivers.
  • If your graphics card is from Nvidia, do not use version 378.49 of the driver, it is broken and does not work with Minecraft! Install the version 378.57 hotfix or update to a newer version of the driver.
  • If you're on Windows 10, see this page.
  • If you're on Windows 10 and have an old Intel HD Graphics chipset, you need to downgrade to an older Java version:
    • Easy solution: Install the standard Minecraft launcher from the Minecraft download page. It will automatically install the proper Java version. Then change the Java path in the ATLauncher options to the standard Minecraft launcher's Java.
    • More complicated solution: Uninstall all Java versions you have installed, then download Java 8 Update 51 from Oracle's website. First, go to this page and accept the license agreement. The links on that page require an Oracle account, but you can use the following links without an account (after accepting the license agreement): 64-bit, 32-bit
  • If your computer has both integrated and a dedicated graphics, open the graphics driver settings/control panel and make sure that Java/Minecraft (java.exe and javaw.exe) is set to use the dedicated graphics card. Otherwise you may experience low framerates or the game might not be able to run at all.

I updated my instance and it crashes before I get to the main menu!
Look at the issues below and see if any of those apply to you. If not, try making a new instance with the same version and mod selection, and see if that launches. If so, you can copy your worlds over to the new instance and use it instead of your old one. (When updating an instance, it is possible that files from old versions aren't updated or deleted properly. New instances logically can't have any such leftover files.)

I'm on Windows 10, and the game hangs/crashes while loading!
Some graphics drivers on Windows 10 don't work well with Forge's loading screen. As a temporary fix, you can disable the loading screen. Open your instance folder, go to the config folder, and edit the splash.properties file with a plain text editor (like Notepad). Find the enabled option and set it to false.
Note that the loading screen only exists in somewhat recent versions of Forge for 1.7.10. On older modpacks the loading screen doesn't exist yet and your crash must be caused by something else.

The game crashes after step 7/7 on the loading bar, with this exception:
Code:
java.lang.RuntimeException: java.lang.IllegalStateException: From thread Thread[Client thread,5,main]: Thread[Thread-8,5,] already has the context current
Edit your instance's options.txt and set the fullscreen option to false. Minecraft's built-in fullscreen mode causes problems with Forge's loading screen on certain systems (usually Mac OS X). If you are on OS X, you can use the system's fullscreen/maximize button on the window title bar instead to play in fullscreen mode.

The game randomly crashes with one of these exceptions:
Code:
java.io.FileNotFoundException: **USERSDIR**\Instances\InstanceName\SomeFilePath (The requested operation cannot be performed on a file with a user-mapped section open)
Code:
java.io.FileNotFoundException: **USERSDIR**\Instances\InstanceName\SomeFilePath (The process cannot access the file because it is being used by another process)
Another program on your computer is accessing some game files while Minecraft is running, which causes certain mods to crash. This is usually caused by antivirus programs' virus scans or realtime protection. Whitelist/exclude/ignore the launcher folder in your antivirus program.

I'm trying to play an old 1.6 modpack, and the game crashes with this exception:
Code:
java.util.ConcurrentModificationException
To play old modpacks with new Java versions, you need to install the Legacy Java Fixer mod. See this sticky thread for more info.


Server Problems

I'm on Windows and get this error:
Code:
Error occurred during initialization of VM
Could not reserve enough space for 2097152KB object heap
(The KB amount might be different.)
The server is being launched with a 32-bit Java version although you are on a 64-bit system. See this FAQ entry on how to install the right Java version for your system.

I'm on a Mac and have problems running a server!
See this sticky thread for a full step-by-step guide on how to properly set up a server on OS X.

The server crashes before starting up and shows no clear error message or traceback!
Edit the eula.txt file in the server folder and accept the EULA.

I can start and join my server, but I can't find any mod resources and I can't craft any modded items!
You've launched the normal Minecraft server jar, which is a vanilla server that does not load Forge or any other mods. Use the LaunchServer script for your system (bat on Windows, sh on OS X/Linux/other Unixes) or run the Forge jar to properly run the server with mods.

After doing this, you should delete the world folder from your server and let the world be regenerated again with mods loaded. Otherwise all parts of the world that were already generated will not have any modded ores and other resources in them.

I have a server on an old modpack version, how do I update it to the current version?
The easiest and safest way to update a server is to not actually update it, but instead make a new server installation and copy all data to the new server folder. Not only does this ensure that all files are up to date, but you also keep the old server intact, meaning that if the update goes wrong you can safely go back to the old version.

In the launcher, use the Create Server button to make a server instance of the version you want to update to. Make sure that you select any optional mods that were also installed on the old server. Now go into your old server folder and copy the world folder and the server.properties file to the new server folder. If you have modified any other server files, copy those over as well - but be careful, if you copy over old configs, you might overwrite config changes from the update.

If there are many optional mods that you want to install, it can be easier to first make a client instance with the mods you want, generate a share code for it (right-click the instance image) and use that share code to create the new server. You can also give the share code to people playing on the server so they can easily install the same mod selection.
Reference URL's