ATLauncher Forums

Full Version: Updating forge?
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
When I try to add a mod that requires a newer version of forge, I download a newer version of forge, put it into the jarmods folder and disable/delete the old one. Yet when I launch the game it still asks for a newer version.

So I figure it's written somewhere in a file which version it is supposed to use, yet I cannot for the life of me figure out where that is. I tried the instance.json file, didn't work.

I know there is no official support for adding your own mods to the modpack, but I was hoping I could get an answer to this question regardless. Any help would be appreciated, even if I can just get pointed in another direction.
Manually putting things in the jarmods doesn't work, in fact it tends to break the jar mod system. If possible, move the old Forge jar back into the jarmods folder. Then click Edit Mods on your instance, disable Forge there, and add the new Forge as a jar mod. Don't forget to enable it afterwards, mods that you just added are disabled by default.
Awesome, that seemed to work just fine.

Now for the big question, how do I update forge on a server?
There should be a file named forge-something.jar (with "something" being some version number) in the main server folder. You should just be able to put the new server jar in the folder and move the old one away, though you may have to rename the new jar to the same name as the old one.
Seems to work as well, thanks a bunch.
apparently, nobody asked the question since August, but today I don't see better place to ask how to updating Forge...Huh
I suppose that Linkitch wanted to update Forge from the "forge-1.7.10-" version to the "forge-1.7.10-" version..
And effectively no problem for theses versions, the solution of dgelessus works very well, I managed to install the JourneyMap4.0.5_Unlimited_MC1.7.10.

But now, with the forge-1.7.10-, the last recommended build, this method doesn't work any more. When I click the play button on my instance, I return on it after few seconds, without launching Minecraft.
I tried the intermediate forge-1.7.10- version, but that makes me the same thing.

Thus I ask to you for it humbly, how did you update Forge on this modpack to add recent mods.

-> The mods which requires (via launcher and .log) the forge-1.7.10- version are "More-Planet's-BETA-1.7.10-1.0.4" by MCCommander_Minecraft, an add-on for Galacticraft 3, and the new JourneyMap5.0.0RC2_Unlimited_MC1.7.10

Please, be kind with me, I'm sorry if it's not the right place to post because I'm new on this forum, and if I made a bad choice of words because I'm french...Tongue
Im not sure there is a mod I know inside out, some are closer than others. The ones I might be able to get completely familiar with, are: AetherCraft, Applied Energistics, Bibliocraft, Enderstorage, Ironchests and/or Lycanites mobs, (also Chisel, but I dont know if that needs its own quest? Tongue)
I hope this helps you,
Just wanted to post this, as I found a, at least for now working, fix.
Using Strill's post here:
I sussed out that forge is the only mod in the jarmods folder, and that when you remove it via the "Edit Mods" option in the launcher, that disappears, but any forge version you add DOESN'T appear there.
So, copy the jar file of the forge you want, paste it into the jarmods folder of the instance you are trying to edit (at least on Windows), and delete the one you don't want. Then have fun trying to figure out which mods need to be updated by trial and error. XD
Reference URL's