ATLauncher Forums
Remove permgen setting if using java version 8 - Printable Version

+- ATLauncher Forums (https://forums.atlauncher.com)
+-- Forum: ATLauncher Forums (/forum-1.html)
+--- Forum: ATLauncher Support (/forum-5.html)
+---- Forum: ATLauncher Suggestions (/forum-49.html)
+---- Thread: Remove permgen setting if using java version 8 (/thread-3758.html)



Remove permgen setting if using java version 8 - Un0Du0 - 08-06-2014 03:35 AM

Hello,

I love this launcher, it works great!

One suggestion is when you have Java version 8 installed, you do not require the permgen setting as it dynamically allocates needed memory, which has 2 benefits, it only uses what ram it needs, plus if there is a new modpack that needs more, you don't need to change the setting.

I know it's a small amount of ram we are dealing with, but on a system that barely runs Minecraft needs every MB


RE: Remove permgen setting if using java version 8 - RyanTheAllmighty - 09-06-2014 12:18 AM

In the next update PermGen is no longer used in Java 8 and above installs as it's switched to MetaSpace